Thursday, January 13, 2011

IL Merge and the 4.0 runtime

If you are trying to ILMerge 4.0 assemblies make sure that you do the following:

Do NOT specify the /targetplatform:v4 as a command line parameter to ILMerge.exe

Create a file called ILMerge.exe.config and enter the following lines

<?xml version ="1.0"?>
<startup useLegacyV2RuntimeActivationPolicy="true">
<requiredRuntime safemode="true" imageVersion="v4.0.30319" version="v4.0.30319"/>

That’s it!!!

No comments: